python快捷安装库-易语言

发布于 2022-05-24  98 次阅读


.版本 2

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击

.判断开始 (组合框2.内容 = “python官方”)
    运行 (“cmd /c pip3 install ” + 组合框1.内容 + “&pause”, 真, 2)

.判断 (组合框2.内容 = “阿里云”)
    运行 (“cmd /c pip3 install -i http://mirrors.aliyun.com/pypi/simple/ ” + 组合框1.内容 + “&pause”, 真, 2)


.判断 (组合框2.内容 = “豆瓣”)
    运行 (“cmd /c pip3 install -i http://pypi.douban.com/simple/ ” + 组合框1.内容 + “&pause”, 真, 2)


.判断 (组合框2.内容 = “清华”)
    运行 (“cmd /c pip3 install -i https://pypi.tuna.tsinghua.edu.cn/simple ” + 组合框1.内容 + “&pause”, 真, 2)


.判断 (组合框2.内容 = “腾讯”)
    运行 (“cmd /c pip3 install -i https://mirrors.tencent.com/pypi/simple ” + 组合框1.内容 + “&pause”, 真, 2)

.默认

.判断结束



.子程序 _按钮2_被单击

运行 (“cmd /c python -m pip install --upgrade pip” + “&pause”, 真, 2)


.子程序 _按钮3_被单击

运行 (“cmd /c python -m pip freeze or pip list” + “&pause”, 真, 2)

.子程序 _按钮4_被单击

运行 (“cmd /c  pip list -o” + “&pause”, 真, 2)

.子程序 _按钮5_被单击

运行 (“cmd /c pip3 help &pause”, 真, 2)

python快捷安装库-易语言插图

主要用来安装各种便捷库,省一部分命令